爱查股网 www.bc073.com 股票查询最好股票网 个股数据查询好股网 关闭本站广告
爱查股网
股票查询最好股票网 个股数据查询好股网
您的位置:爱查股网 > 股票公式 > 通达信公式
股票公式搜索:

通达信区分顶底背离指标公式

2021/4/7 18:32:47

底:-50;
顶:50;
TRR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TRR;
MDI:= MDM*100/TRR;
A1:=BARSLAST(REF(CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIF"(12,26,9),A1+1)<"MACD.DIF"(12,26,9) AND CROSS("MACD.DIF"(12,26,9),"MACD.DEA"(12,26,9));
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF"(12,26,9),C1+1)>"MACD.DIF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIF"(12,26,9));
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
C4:=BARSLAST(REF(CROSS(MDI,PDI),1));
D4:=REF(C,C+1)<C AND REF(MDI,C4+1)>MDI AND CROSS(MDI,PDI);
A4:=BARSLAST(REF(CROSS(PDI,MDI),1));
B4:=REF(C,A4+1)>C AND REF(PDI,A4+1)<PDI AND CROSS(PDI,MDI);
DMI底背:IF(B4>0,-50,0),COLOR0099FF,POINTDOT;
DRAWTEXT(B4>0,-5,'DMI底背'),COLOR0099FF;
DMI顶背:IF(D4>0,50,0),COLORBLUE,POINTDOT;
DRAWTEXT(D4>0,15,'DMI顶背'),COLORBLUE;
MACD底背:IF(B1>0,-50,0),COLORRED,POINTDOT;
DRAWTEXT(B1>0,-15,'MACD底背'),COLORRED;
KDJ底背:IF(B2>0,-50,0),COLORFF00FF,POINTDOT;
DRAWTEXT(B2>0,-25,'KDJ底背'),COLORFF00FF;
RSI底背:IF(B3>0,-50,0),COLORYELLOW,POINTDOT;
DRAWTEXT(B3>0,-35,'RSI底背'),COLORYELLOW;
MACD顶背:IF(D1>0,50,0),COLOR00FF00,POINTDOT;
DRAWTEXT(D1>0,25,'MACD顶背'),COLOR00FF00;
KDJ顶背:IF(D2>0,50,0),COLORFFCC66,POINTDOT;
DRAWTEXT(D2>0,35,'KDJ顶背'),COLORFFCC66;
RSI顶背:IF(D3>0,50,0),COLORFFFFFF,POINTDOT;
DRAWTEXT(D3>0,45,'RSI顶背'),COLORFFFFFF;
STICKLINE(B1>0,-50,0,0,0),COLORRED;
STICKLINE(B2>0,-50,0,0,0),COLORFF00FF;
STICKLINE(B3>0,-50,0,0,0),COLORYELLOW;
STICKLINE(D1>0,50,0,0,0),COLOR00FF00;
STICKLINE(D2>0,50,0,0,0),COLORFFCC66;
STICKLINE(D3>0,50,0,0,0),COLORWHITE;
STICKLINE(B4>0,-50,0,0,0),COLOR0099FF;
STICKLINE(D4>0,50,0,0,0),COLORBLUE;


爱查 股网 www.aichag u.com

[源码注释]通达信公式动态翻译结果
 输出底:-50
输出顶:50
赋值: 最高价-最低价和最高价-1日前的收盘价的绝对值的较大值和最低价-1日前的收盘价的绝对值的较大值的14日累和
赋值: 最高价-1日前的最高价
赋值: 1日前的最低价-最低价
PDM赋值: 如果HD>0ANDHD>LD,返回HD,否则返回0的14日累和
MDM赋值: 如果LD>0ANDLD>HD,返回LD,否则返回0的14日累和
PDI赋值: PDM*100/TRR
MDI赋值: MDM*100/TRR
A1赋值:上次1日前的"平滑异同平均的DIF"(12,26,9)上穿"平滑异同平均的DEA"(12,26,9)距今天数
B1赋值:A1+1日前的收盘价>收盘价 AND A1+1日前的"平滑异同平均的DIF"(12,26,9)<"平滑异同平均的DIF"(12,26,9) AND "平滑异同平均的DIF"(12,26,9)上穿"平滑异同平均的DEA"(12,26,9)
A2赋值:上次1日前的"KDJ的K"(9,3,3)上穿"KDJ的D"(9,3,3)距今天数
B2赋值:A2+1日前的收盘价>收盘价 AND A2+1日前的"KDJ的K"(9,3,3)<"KDJ的K"(9,3,3) AND "KDJ的K"(9,3,3)上穿"KDJ的D"(9,3,3)
A3赋值:上次1日前的"RSI的RSI1"(6,12,24)上穿"RSI的RSI2"(6,12,24)距今天数
B3赋值:A3+1日前的收盘价>收盘价 AND A3+1日前的"RSI的RSI1"(6,12,24)<"RSI的RSI1"(6,12,24) AND "RSI的RSI1"(6,12,24)上穿"RSI的RSI2"(6,12,24)
C1赋值:上次1日前的"平滑异同平均的DEA"(12,26,9)上穿"平滑异同平均的DIF"(12,26,9)距今天数
D1赋值:C1+1日前的收盘价<收盘价 AND C1+1日前的"平滑异同平均的DIF"(12,26,9)>"平滑异同平均的DIF"(12,26,9) AND "平滑异同平均的DEA"(12,26,9)上穿"平滑异同平均的DIF"(12,26,9)
C2赋值:上次1日前的"KDJ的D"(9,3,3)上穿"KDJ的K"(9,3,3)距今天数
D2赋值:C2+1日前的收盘价<收盘价 AND C2+1日前的"KDJ的K"(9,3,3)>"KDJ的K"(9,3,3) AND "KDJ的D"(9,3,3)上穿"KDJ的K"(9,3,3)
C3赋值:上次1日前的"RSI的RSI2"(6,12,24)上穿"RSI的RSI1"(6,12,24)距今天数
D3赋值:C3+1日前的收盘价<收盘价 AND C3+1日前的"RSI的RSI1"(6,12,24)>"RSI的RSI1"(6,12,24) AND "RSI的RSI2"(6,12,24)上穿"RSI的RSI1"(6,12,24)
C4赋值:上次1日前的MDI上穿PDI距今天数
D4赋值:收盘价+1日前的收盘价<收盘价 AND C4+1日前的MDI>MDI AND MDI上穿PDI
A4赋值:上次1日前的PDI上穿MDI距今天数
B4赋值:A4+1日前的收盘价>收盘价 AND A4+1日前的PDI<PDI AND PDI上穿MDI
输出DMI底背:如果B4>0,返回-50,否则返回0,COLOR0099FF,POINTDOT
当满足条件B4>0时,在-5位置书写文字,COLOR0099FF
输出DMI顶背:如果D4>0,返回50,否则返回0,画蓝色,POINTDOT
当满足条件D4>0时,在15位置书写文字,画蓝色
输出MACD底背:如果B1>0,返回-50,否则返回0,画红色,POINTDOT
当满足条件B1>0时,在-15位置书写文字,画红色
输出KDJ底背:如果B2>0,返回-50,否则返回0,COLORFF00FF,POINTDOT
当满足条件B2>0时,在-25位置书写文字,COLORFF00FF
输出RSI底背:如果B3>0,返回-50,否则返回0,画黄色,POINTDOT
当满足条件B3>0时,在-35位置书写文字,画黄色
输出MACD顶背:如果D1>0,返回50,否则返回0,COLOR00FF00,POINTDOT
当满足条件D1>0时,在25位置书写文字,COLOR00FF00
输出KDJ顶背:如果D2>0,返回50,否则返回0,COLORFFCC66,POINTDOT
当满足条件D2>0时,在35位置书写文字,COLORFFCC66
输出RSI顶背:如果D3>0,返回50,否则返回0,COLORFFFFFF,POINTDOT
当满足条件D3>0时,在45位置书写文字,COLORFFFFFF
当满足条件B1>0时,在-50和0位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件B2>0时,在-50和0位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF00FF
当满足条件B3>0时,在-50和0位置之间画柱状线,宽度为0,0不为0则画空心柱.,画黄色
当满足条件D1>0时,在50和0位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FF00
当满足条件D2>0时,在50和0位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFCC66
当满足条件D3>0时,在50和0位置之间画柱状线,宽度为0,0不为0则画空心柱.,画白色
当满足条件B4>0时,在-50和0位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0099FF
当满足条件D4>0时,在50和0位置之间画柱状线,宽度为0,0不为0则画空心柱.,画蓝色

股票公式推荐
在线查股
个股查股导航:股票行情查询 DDX在线查询 超赢数据查询 资金流向 千股千评 个股最新消息 大小非解禁 十大股东查询 分红配股查询 业绩预告查询
莱克电气 603355+3.93% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
永新光学 603297+3.92% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
江河集团 601886+3.90% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
苏泊尔 002032+3.89% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
永安行 603776+3.89% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
怡亚通 002183+3.89% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
联环药业 600513+3.88% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
海天股份 603759+3.87% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
吉药控股 300108+3.87% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
佳沃股份 300268+3.86% 千股千评 DDX指标 超赢 资金 大小非 股东 分红
商务合作:在线客服
爱查股网不推荐股票,不收会员,网站内的广告不代表本股票网的观点,由此引起的一切法律责任均与本站无关,股市有风险,投资需谨慎。粤ICP备17111814号-1
特别提示:本站不为所提供数据的错误、残缺、延迟或因依靠此信息所采取的任何行为负责。本股票网提供的所有内容仅供参考,不构成投资建议,投资者据此操作,风险自担。
手机版(手机访问当前页面) | 电脑端(适合电脑或大屏用户)
国产真实乱对白精彩,黄网站男人免费大全,台湾自拍偷区亚洲综合,最新中文乱码字字幕在线 网站地图